summaryrefslogtreecommitdiffstats
path: root/src/plugins/map/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/map/CMakeLists.txt')
-rw-r--r--src/plugins/map/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/plugins/map/CMakeLists.txt b/src/plugins/map/CMakeLists.txt
index 1dc1bedb51c..a3e6e3d2540 100644
--- a/src/plugins/map/CMakeLists.txt
+++ b/src/plugins/map/CMakeLists.txt
@@ -11,8 +11,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-add_vpp_plugin(map_plugin
- map.api
+add_vpp_plugin(map
+ SOURCES
ip4_map.c
ip4_map_t.c
ip6_map.c
@@ -20,4 +20,7 @@ add_vpp_plugin(map_plugin
map_api.c
map.c
map_dpo.c
+
+ API_FILES
+ map.api
)