aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/marvell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/marvell/CMakeLists.txt')
-rw-r--r--src/plugins/marvell/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/plugins/marvell/CMakeLists.txt b/src/plugins/marvell/CMakeLists.txt
index c606f3d5b81..4e4b76886fa 100644
--- a/src/plugins/marvell/CMakeLists.txt
+++ b/src/plugins/marvell/CMakeLists.txt
@@ -11,10 +11,16 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+if(NOT CMAKE_SYSTEM_PROCESSOR MATCHES "^(aarch64.*|AARCH64.*)")
+ return()
+endif()
+
find_path(MUSDK_INCLUDE_DIR NAMES mv_std.h)
-find_library(MUSDK_LIB NAMES musdk)
+find_library(MUSDK_LIB NAMES libmusdk.a)
if(MUSDK_INCLUDE_DIR AND MUSDK_LIB)
+ get_filename_component(MUSDK_LIB_DIR ${MUSDK_LIB} DIRECTORY)
+ set(MUSDK_LINK_FLAGS "-Wl,--whole-archive,${MUSDK_LIB_DIR}/libmusdk.a,--no-whole-archive")
add_vpp_plugin(marvell
SOURCES
plugin.c
@@ -24,8 +30,8 @@ if(MUSDK_INCLUDE_DIR AND MUSDK_LIB)
pp2/output.c
pp2/pp2.c
- LINK_LIBRARIES
- ${MUSDK_LIB}
+ LINK_FLAGS
+ ${MUSDK_LINK_FLAGS}
)
include_directories(${MUSDK_INCLUDE_DIR})
message(STATUS "Found Marvel MUSDK in ${MUSDK_INCLUDE_DIR}")