aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/nat/CMakeLists.txt')
-rw-r--r--src/plugins/nat/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/plugins/nat/CMakeLists.txt b/src/plugins/nat/CMakeLists.txt
new file mode 100644
index 00000000000..931fa2c7984
--- /dev/null
+++ b/src/plugins/nat/CMakeLists.txt
@@ -0,0 +1,41 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(nat_plugin
+ nat.api
+ nat.c
+ nat_api.c
+ in2out.c
+ out2in.c
+ nat_ipfix_logging.c
+ nat_det.c
+ nat_reass.c
+ nat_dpo.c
+ nat44_cli.c
+ nat64.c
+ nat64_cli.c
+ nat64_in2out.c
+ nat64_out2in.c
+ nat64_db.c
+ dslite_dpo.c
+ dslite.c
+ dslite_in2out.c
+ dslite_out2in.c
+ dslite_cli.c
+ dslite_ce_encap.c
+ dslite_ce_decap.c
+ nat66.c
+ nat66_cli.c
+ nat66_in2out.c
+ nat66_out2in.c
+)