summaryrefslogtreecommitdiffstats
path: root/src/plugins/perfmon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/perfmon/CMakeLists.txt')
-rw-r--r--src/plugins/perfmon/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/plugins/perfmon/CMakeLists.txt b/src/plugins/perfmon/CMakeLists.txt
index 845dd3cc6c8..340c5608f33 100644
--- a/src/plugins/perfmon/CMakeLists.txt
+++ b/src/plugins/perfmon/CMakeLists.txt
@@ -23,3 +23,11 @@ install(
DESTINATION share/vpp/plugins/perfmon
COMPONENT vpp-dev
)
+
+option(VPP_BUILD_MAPFILE_TOOL "Build perfmon mapfile utility." OFF)
+if(VPP_BUILD_MAPFILE_TOOL)
+ add_vpp_executable(mapfile_tool
+ SOURCES mapfile_tool.c
+ LINK_LIBRARIES vppinfra Threads::Threads
+ )
+endif(VPP_BUILD_MAPFILE_TOOL)