aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/perfmon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/perfmon/CMakeLists.txt')
-rw-r--r--src/plugins/perfmon/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/plugins/perfmon/CMakeLists.txt b/src/plugins/perfmon/CMakeLists.txt
new file mode 100644
index 00000000000..c0d39a39838
--- /dev/null
+++ b/src/plugins/perfmon/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+if(NOT CMAKE_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
+ return()
+endif()
+
+add_vpp_plugin(perfmon
+ SOURCES
+ cli.c
+ dispatch_wrapper.c
+ linux.c
+ perfmon.c
+ table.c
+ intel/core.c
+ intel/uncore.c
+ intel/bundle/inst_and_clock.c
+ intel/bundle/load_blocks.c
+ intel/bundle/mem_bw.c
+)