summaryrefslogtreecommitdiffstats
path: root/src/plugins/srtp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/srtp/CMakeLists.txt')
-rw-r--r--src/plugins/srtp/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/src/plugins/srtp/CMakeLists.txt b/src/plugins/srtp/CMakeLists.txt
index acbdf3177d8..5771ad2dc36 100644
--- a/src/plugins/srtp/CMakeLists.txt
+++ b/src/plugins/srtp/CMakeLists.txt
@@ -11,15 +11,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-include (CheckFunctionExists)
-
vpp_plugin_find_library(srtp SRTP_LIB libsrtp2.a)
-
-if (NOT SRTP_LIB)
- message(WARNING "srtp plugin - srtp2 lib not found - plugin disabled")
- return()
-endif()
-
vpp_find_path(SRTP_INCLUDE_DIR NAMES srtp2/srtp.h)
if (NOT SRTP_INCLUDE_DIR)
@@ -29,9 +21,6 @@ endif()
include_directories (${SRTP_INCLUDE_DIR})
-set(CMAKE_REQUIRED_FLAGS "-fPIC -shared -pthread -Wno-unused-command-line-argument ${SRTP_LIB}")
-set(CMAKE_REQUIRED_INCLUDES "${SRTP_INCLUDE_DIR}")
-
add_vpp_plugin(srtp
SOURCES
srtp.c