summaryrefslogtreecommitdiffstats
path: root/src/tools/perftool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/perftool/CMakeLists.txt')
-rw-r--r--src/tools/perftool/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/tools/perftool/CMakeLists.txt b/src/tools/perftool/CMakeLists.txt
new file mode 100644
index 00000000000..fd9fb0a286b
--- /dev/null
+++ b/src/tools/perftool/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+option(VPP_BUILD_PERFTOOL "Build Perf tool" OFF)
+if (VPP_BUILD_PERFTOOL)
+ add_vpp_library(cperf
+ SOURCES
+ delsvec.c
+ linreg.c
+ props.c
+ cpel_util.c
+ )
+
+ foreach(name
+ c2cpel
+ cpelatency
+ cpeldump
+ cpelinreg
+ cpelstate
+ elog_merge
+ )
+ add_vpp_executable(${name} SOURCES ${name}.c
+ LINK_LIBRARIES cperf vppinfra m)
+ endforeach()
+endif()