summaryrefslogtreecommitdiffstats
path: root/src/vat2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vat2/CMakeLists.txt')
-rw-r--r--src/vat2/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/vat2/CMakeLists.txt b/src/vat2/CMakeLists.txt
new file mode 100644
index 00000000000..690267c6113
--- /dev/null
+++ b/src/vat2/CMakeLists.txt
@@ -0,0 +1,43 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+##############################################################################
+# vat2
+##############################################################################
+add_vpp_executable(vat2 ENABLE_EXPORTS NO_INSTALL
+ SOURCES
+ main.c
+ plugin.c
+ jsonconvert.c
+
+ DEPENDS api_headers
+
+ LINK_LIBRARIES
+ vlibmemoryclient
+ svm
+ vppinfra
+ vppapiclient
+ Threads::Threads
+ rt m dl crypto
+)
+
+##############################################################################
+# vat2 headers
+##############################################################################
+install(
+ FILES
+ jsonconvert.h
+ vat2_helpers.h
+ DESTINATION include/vat2
+ COMPONENT vpp-dev
+)