summaryrefslogtreecommitdiffstats
path: root/src/vlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vlib/CMakeLists.txt')
-rw-r--r--src/vlib/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/vlib/CMakeLists.txt b/src/vlib/CMakeLists.txt
index c2a0d63f4d8..67d1f6d05c7 100644
--- a/src/vlib/CMakeLists.txt
+++ b/src/vlib/CMakeLists.txt
@@ -11,9 +11,17 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+option(VPP_BUFFER_FAULT_INJECTOR "Include the buffer fault injector" OFF)
+
##############################################################################
# Generate vlib/config.h
##############################################################################
+if(VPP_BUFFER_FAULT_INJECTOR)
+ set(BUFFER_ALLOC_FAULT_INJECTOR 1 CACHE STRING "fault injector on")
+else()
+ set(BUFFER_ALLOC_FAULT_INJECTOR 0 CACHE STRING "fault injector off")
+endif()
+
set(PRE_DATA_SIZE 128 CACHE STRING "Buffer headroom size.")
configure_file(
${CMAKE_SOURCE_DIR}/vlib/config.h.in