aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index e486aa97510..b6028e90742 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -531,6 +531,20 @@ list(APPEND VNET_SOURCES
list(APPEND VNET_API_FILES bfd/bfd.api)
##############################################################################
+# Crypto
+##############################################################################
+
+list(APPEND VNET_SOURCES
+ crypto/cli.c
+ crypto/crypto.c
+ crypto/format.c
+)
+
+list(APPEND VNET_HEADERS
+ crypto/crypto.h
+)
+
+##############################################################################
# Layer 3 protocol: IPSec
##############################################################################
list(APPEND VNET_SOURCES