summaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 9c1bceb5753..7120809636e 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -941,6 +941,24 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_API_FILES ipfix-export/ipfix_export.api)
##############################################################################
+# GSO
+##############################################################################
+list(APPEND VNET_SOURCES
+ gso/cli.c
+ gso/gso.c
+ gso/gso_api.c
+ gso/node.c
+)
+
+list(APPEND VNET_HEADERS
+ gso/gso.h
+)
+
+list(APPEND VNET_API_FILES
+ gso/gso.api
+)
+
+##############################################################################
# IPFIX classify code
##############################################################################