summaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index cb730ba227f..1b1df863bf7 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -42,6 +42,7 @@ list(APPEND VNET_SOURCES
list(APPEND VNET_MULTIARCH_SOURCES
interface_output.c
interface_stats.c
+ handoff.c
)
list(APPEND VNET_HEADERS
@@ -135,7 +136,10 @@ list(APPEND VNET_SOURCES
ethernet/p2p_ethernet_api.c
)
-list(APPEND VNET_MULTIARCH_SOURCES ethernet/node.c)
+list(APPEND VNET_MULTIARCH_SOURCES
+ ethernet/node.c
+ ethernet/p2p_ethernet_input.c
+)
list(APPEND VNET_HEADERS
ethernet/error.def
@@ -727,6 +731,11 @@ list(APPEND VNET_SOURCES
l2tp/l2tp_api.c
)
+list(APPEND VNET_MULTIARCH_SOURCES
+ l2tp/encap.c
+ l2tp/decap.c
+)
+
list(APPEND VNET_HEADERS
l2tp/l2tp.h
l2tp/packet.h
@@ -823,6 +832,10 @@ list(APPEND VNET_SOURCES
ipsec-gre/ipsec_gre_api.c
)
+list(APPEND VNET_MULTIARCH_SOURCES
+ ipsec-gre/node.c
+)
+
list(APPEND VNET_HEADERS
ipsec-gre/ipsec_gre.h
ipsec-gre/error.def
@@ -899,6 +912,10 @@ list(APPEND VNET_SOURCES
dhcp/dhcp_api.c
)
+list(APPEND VNET_MULTIARCH_SOURCES
+ dhcp/dhcp_client_detect.c
+)
+
list(APPEND VNET_HEADERS
dhcp/client.h
dhcp/dhcp6_client_common_dp.h
@@ -1001,6 +1018,10 @@ list(APPEND VNET_SOURCES
lawful-intercept/node.c
)
+list(APPEND VNET_MULTIARCH_SOURCES
+ lawful-intercept/node.c
+)
+
list(APPEND VNET_HEADERS
lawful-intercept/lawful_intercept.h
)