aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp-api/python/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vpp-api/python/CMakeLists.txt')
-rw-r--r--src/vpp-api/python/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/vpp-api/python/CMakeLists.txt b/src/vpp-api/python/CMakeLists.txt
index 910df6bfd6b..6450fd92f2d 100644
--- a/src/vpp-api/python/CMakeLists.txt
+++ b/src/vpp-api/python/CMakeLists.txt
@@ -11,7 +11,11 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-find_package(Python3 COMPONENTS Interpreter)
+if (CMAKE_VERSION VERSION_LESS 3.12)
+ find_package(PythonInterp 2.7)
+else()
+ find_package(Python3 COMPONENTS Interpreter)
+endif()
if(PYTHONINTERP_FOUND)
install(