aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp-api/python/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vpp-api/python/CMakeLists.txt')
-rw-r--r--src/vpp-api/python/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/vpp-api/python/CMakeLists.txt b/src/vpp-api/python/CMakeLists.txt
index 6450fd92f2d..789a72233e6 100644
--- a/src/vpp-api/python/CMakeLists.txt
+++ b/src/vpp-api/python/CMakeLists.txt
@@ -15,6 +15,8 @@ if (CMAKE_VERSION VERSION_LESS 3.12)
find_package(PythonInterp 2.7)
else()
find_package(Python3 COMPONENTS Interpreter)
+ set(PYTHONINTERP_FOUND ${Python3_Interpreter_FOUND})
+ set(PYTHON_EXECUTABLE ${Python3_EXECUTABLE})
endif()
if(PYTHONINTERP_FOUND)
@@ -24,11 +26,10 @@ if(PYTHONINTERP_FOUND)
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
COMMAND ${PYTHON_EXECUTABLE} ./setup.py
install
- --root /
+ --root=\$ENV{DESTDIR}/
--prefix=${CMAKE_INSTALL_PREFIX}
--single-version-externally-managed
bdist_egg
- --dist-dir=${CMAKE_INSTALL_PREFIX}
OUTPUT_QUIET
)"
COMPONENT vpp-api-python