summaryrefslogtreecommitdiffstats
path: root/src/vpp-api/vapi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vpp-api/vapi/CMakeLists.txt')
-rw-r--r--src/vpp-api/vapi/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/vpp-api/vapi/CMakeLists.txt b/src/vpp-api/vapi/CMakeLists.txt
index abf9ffb14fa..120bfd4d69f 100644
--- a/src/vpp-api/vapi/CMakeLists.txt
+++ b/src/vpp-api/vapi/CMakeLists.txt
@@ -33,7 +33,11 @@ foreach(f ${VPP_API_FILES})
DEPENDS ${input} vapi_c_gen.py vapi_json_parser.py api_headers
COMMENT "Generating VAPI C header ${output}"
)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${output} DESTINATION include/vapi)
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${output}
+ DESTINATION include/vapi
+ COMPONENT vpp-dev
+ )
list(APPEND VAPICLIENT_API_CPP_HEADERS ${output})
# C++ VAPI Headers
@@ -46,7 +50,11 @@ foreach(f ${VPP_API_FILES})
DEPENDS ${input} vapi_cpp_gen.py vapi_json_parser.py api_headers
COMMENT "Generating VAPI C++ header ${output}"
)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${output} DESTINATION include/vapi)
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${output}
+ DESTINATION include/vapi
+ COMPONENT vpp-dev
+ )
list(APPEND VAPICLIENT_API_CPP_HEADERS ${output})
endforeach ()
@@ -73,4 +81,5 @@ install(
vapi_internal.h
DESTINATION include/vapi
+ COMPONENT vpp-dev
)