summaryrefslogtreecommitdiffstats
path: root/vlib-api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vlib-api/Makefile.am')
-rw-r--r--vlib-api/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/vlib-api/Makefile.am b/vlib-api/Makefile.am
index 4b0129a3a5f..5bc00e7479b 100644
--- a/vlib-api/Makefile.am
+++ b/vlib-api/Makefile.am
@@ -75,3 +75,7 @@ SUFFIXES = .api.h .api
mkdir -p `dirname $@` ; \
$(CC) $(CPPFLAGS) -E -P -C -x c $^ \
| vppapigen --input - --output $@ --show-name $@
+
+# install the API definition, so we can produce java bindings, etc.
+apidir = $(prefix)/vlibmemory
+api_DATA = vlibmemory/memclnt.api