aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 44ce1077c21..f44bb12492c 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -59,6 +59,18 @@ nobase_include_HEADERS += \
vnet/policer/police.h \
vnet/policer/xlate.h
+########################################
+# Cop - junk filter
+########################################
+
+libvnet_la_SOURCES += \
+ vnet/cop/cop.c \
+ vnet/cop/node1.c \
+ vnet/cop/ip4_whitelist.c \
+ vnet/cop/ip6_whitelist.c
+
+nobase_include_HEADERS += \
+ vnet/cop/cop.h
########################################
# Layer 2 protocols go here