aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index bb138e6b0d7..44ce1077c21 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -191,10 +191,21 @@ libvnet_la_SOURCES += \
nobase_include_HEADERS += \
vnet/vxlan/vxlan.h \
- vnet/vxlan/vxlan_packet.h \
+ vnet/vxlan/vxlan_packet.h \
vnet/vxlan/vxlan_error.def
########################################
+# Layer 2 / CDP
+########################################
+libvnet_la_SOURCES += \
+ vnet/cdp/cdp_input.c \
+ vnet/cdp/cdp_node.c \
+ vnet/cdp/cdp_periodic.c
+
+nobase_include_HEADERS += \
+ vnet/cdp/cdp_protocol.h
+
+########################################
# Layer 2/3 "classify"
########################################
libvnet_la_SOURCES += \