summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index cf1fb1e0ab3..ff8a31dae26 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -607,6 +607,19 @@ nobase_include_HEADERS += \
vnet/devices/ssvm/ssvm_eth.h
########################################
+# Linux packet interface
+########################################
+
+libvnet_la_SOURCES += \
+ vnet/devices/af_packet/af_packet.c \
+ vnet/devices/af_packet/device.c \
+ vnet/devices/af_packet/node.c \
+ vnet/devices/af_packet/cli.c
+
+nobase_include_HEADERS += \
+ vnet/devices/af_packet/af_packet.h
+
+########################################
# Unix kernel related
########################################