summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index a69734d1530..9393c1a8772 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -397,6 +397,15 @@ nobase_include_HEADERS += \
########################################
+# NSH Map: nsh
+########################################
+
+nobase_include_HEADERS += \
+ vnet/nsh/nsh_packet.h \
+ vnet/nsh/nsh_error.def
+
+
+########################################
# Tunnel protocol: nsh-gre
########################################
@@ -406,9 +415,7 @@ libvnet_la_SOURCES += \
vnet/nsh-gre/decap.c
nobase_include_HEADERS += \
- vnet/nsh-gre/nsh_gre.h \
- vnet/nsh-gre/nsh_gre_packet.h \
- vnet/nsh-gre/nsh_gre_error.def
+ vnet/nsh-gre/nsh_gre.h
########################################
# Tunnel protocol: nsh-vxlan-gpe