summaryrefslogtreecommitdiffstats
path: root/vpp-api/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'vpp-api/python/setup.py')
-rw-r--r--vpp-api/python/setup.py30
1 files changed, 24 insertions, 6 deletions
diff --git a/vpp-api/python/setup.py b/vpp-api/python/setup.py
index e369a0cb479..a2eeff3f436 100644
--- a/vpp-api/python/setup.py
+++ b/vpp-api/python/setup.py
@@ -1,16 +1,34 @@
+#
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
try:
- from setuptools import setup
+ from setuptools import setup, command, Extension
except ImportError:
from distutils.core import setup
setup (name = 'vpp_papi',
- version = '1.1',
+ version = '1.2',
description = 'VPP Python binding',
author = 'Ole Troan',
author_email = 'ot@cisco.com',
- #url = 'https://docs.python.org/extending/building',
test_suite = 'tests',
packages=['vpp_papi'],
- long_description = '''
-VPP Python language binding.
-''',)
+ ext_modules = [
+ Extension(
+ 'vpp_api',
+ sources = ['vpp_papi/pneum_wrap.c'],
+ libraries = ['pneum'],
+ )],
+ long_description = '''VPP Python language binding.''',
+)