summaryrefslogtreecommitdiffstats
path: root/vpp-api/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'vpp-api/python/setup.py')
-rw-r--r--vpp-api/python/setup.py34
1 files changed, 0 insertions, 34 deletions
diff --git a/vpp-api/python/setup.py b/vpp-api/python/setup.py
deleted file mode 100644
index 99a0147a56f..00000000000
--- a/vpp-api/python/setup.py
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# Copyright (c) 2016 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-try:
- from setuptools import setup, Extension
-except ImportError:
- from distutils.core import setup, Extension
-
-setup (name = 'vpp_papi',
- version = '1.3',
- description = 'VPP Python binding',
- author = 'Ole Troan',
- author_email = 'ot@cisco.com',
- test_suite = 'tests',
- packages=['vpp_papi'],
- ext_modules = [
- Extension(
- 'vpp_api',
- sources = ['vpp_papi/pneum_wrap.c'],
- libraries = ['pneum'],
- )],
- long_description = '''VPP Python language binding.''',
-)