aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/Makefile.am')
-rw-r--r--vpp/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/vpp/Makefile.am b/vpp/Makefile.am
index 214cc743093..1c40ed3d57e 100644
--- a/vpp/Makefile.am
+++ b/vpp/Makefile.am
@@ -121,14 +121,13 @@ if WITH_IPV6SR
vpp_LDADD += -lcrypto
endif
+# Set the suffix list
SUFFIXES = .api.h .api
-%.api.h: %.api
- @echo " APIGEN " $@ ; \
- mkdir -p `dirname $@` ; \
- $(CC) $(CPPFLAGS) -E -P -C -x c $^ \
- | vppapigen --input - --output $@ --show-name $@
+# The actual %.api.h rule is in .../build-data/packages/suffix-rules.mk
+# and requires a symbolic link at the top of the vpp source tree
+include $(top_srcdir)/suffix-rules.mk
noinst_PROGRAMS += test_client