summaryrefslogtreecommitdiffstats
path: root/vpp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/configure.ac')
-rw-r--r--vpp/configure.ac39
1 files changed, 24 insertions, 15 deletions
diff --git a/vpp/configure.ac b/vpp/configure.ac
index 8c7beb4d94d..f2756a305ef 100644
--- a/vpp/configure.ac
+++ b/vpp/configure.ac
@@ -7,27 +7,36 @@ AM_PROG_AS
AC_PROG_CC
AM_PROG_CC_C_O
-AC_ARG_WITH(q-plugin-prefix,
- AC_HELP_STRING([--with-q-plugin-prefix],[vlib plugin prefix]),
- [case $with_q_plugin_prefix in
- *) ;;
- esac])
-
-AC_ARG_WITH(q-platform,
- AC_HELP_STRING([--with-q-platform],[Build version for given platform (qnative)]),
- [case $with_q_platform in
- qnative) ;;
- *) with_q_platform=qnative;;
- esac])
-
AC_ARG_WITH(dpdk,
AC_HELP_STRING([--with-dpdk],[Use the Intel dpdk]),
[with_dpdk=1],
[with_dpdk=0])
+AC_ARG_WITH(ipsec,
+ AC_HELP_STRING([--without-ipsec],[Disable ipsec]),
+ [with_ipsec=0],
+ [with_ipsec=1])
+
+AC_ARG_WITH(vcgn,
+ AC_HELP_STRING([--without-vcgn],[Disable vcgn]),
+ [with_vcgn=0],
+ [with_vcgn=1])
+
+AC_ARG_WITH(ipv6sr,
+ AC_HELP_STRING([--without-ipv6sr],[Disable ipv6sr]),
+ [with_ipv6sr=0],
+ [with_ipv6sr=1])
+
AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
-AC_SUBST(Q_PLATFORM_DEFINE,[-DQ_PLATFORM_${with_q_platform}])
-AC_SUBST(Q_PLATFORM_PLUGPATH,[-DQ_PLUGIN_PREFIX=${with_q_plugin_prefix}])
AC_SUBST(DPDK,[-DDPDK=${with_dpdk}])
+AM_CONDITIONAL(WITH_IPSEC, test "$with_ipsec" = "1")
+AC_SUBST(IPSEC,[-DIPSEC=${with_ipsec}])
+
+AM_CONDITIONAL(WITH_VCGN, test "$with_vcgn" = "1")
+AC_SUBST(VCGN,[-DVCGN=${with_vcgn}])
+
+AM_CONDITIONAL(WITH_IPV6SR, test "$with_ipv6sr" = "1")
+AC_SUBST(IPV6SR,[-DIPV6SR=${with_ipv6sr}])
+
AC_OUTPUT([Makefile])