aboutsummaryrefslogtreecommitdiffstats
path: root/vppinfra/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vppinfra/Makefile.am')
-rw-r--r--vppinfra/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/vppinfra/Makefile.am b/vppinfra/Makefile.am
index 388845a4f51..e3a7d46def4 100644
--- a/vppinfra/Makefile.am
+++ b/vppinfra/Makefile.am
@@ -266,3 +266,9 @@ libvppinfra_la_SOURCES = \
vppinfra/timer.c \
vppinfra/unix-formats.c \
vppinfra/unix-misc.c
+
+bin_PROGRAMS = elftool
+
+elftool_SOURCES = tools/elftool.c
+elftool_CPPFLAGS = -Wall
+elftool_LDADD = libvppinfra.la -lpthread -lrt -lm