summaryrefslogtreecommitdiffstats
path: root/vppinfra/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vppinfra/Makefile.am')
-rw-r--r--vppinfra/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/vppinfra/Makefile.am b/vppinfra/Makefile.am
index 3a400163e52..adcd32cc868 100644
--- a/vppinfra/Makefile.am
+++ b/vppinfra/Makefile.am
@@ -20,7 +20,10 @@ endif
lib_LIBRARIES =
-TESTS = test_bihash_template \
+TESTS =
+
+if ENABLE_TESTS
+TESTS += test_bihash_template \
test_elog \
test_elf \
test_fifo \
@@ -44,6 +47,7 @@ TESTS = test_bihash_template \
test_timing_wheel \
test_vec \
test_zvec
+endif
noinst_PROGRAMS = $(TESTS)
check_PROGRAMS = $(TESTS)