aboutsummaryrefslogtreecommitdiffstats
path: root/vppinfra/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'vppinfra/configure.ac')
-rw-r--r--vppinfra/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/vppinfra/configure.ac b/vppinfra/configure.ac
index d0b3a0c0dd2..712186af39d 100644
--- a/vppinfra/configure.ac
+++ b/vppinfra/configure.ac
@@ -31,6 +31,13 @@ AC_ARG_WITH(ldflags,
######################################################################
+AC_ARG_ENABLE(tests,
+ AC_HELP_STRING([--enable-tests],[Enable unit tests]),
+ [enable_tests=1],
+ [enable_tests=0])
+
+AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" = "1")
+
AC_ARG_WITH(unix,
AC_HELP_STRING([--with-unix],[Compile unix version of clib]),
[],