aboutsummaryrefslogtreecommitdiffstats
path: root/netlink/Makefile.am
diff options
context:
space:
mode:
authorPierre Pfister <ppfister@cisco.com>2016-05-11 13:09:21 +0100
committerPierre Pfister <ppfister@cisco.com>2016-05-11 13:09:21 +0100
commit4c0471070eb6141945e7b33194bc80d8c5b8fcab (patch)
tree2633317b86e437183061fa008f2dad9fd33649f8 /netlink/Makefile.am
parent51f92d577e1fd7121b125eb0d39c0cee27c0289b (diff)
Initial commit for the netlink effort
Change-Id: Ie804a9855f20e12f44fe040d15efb710941dee9f Signed-off-by: Pierre Pfister <ppfister@cisco.com>
Diffstat (limited to 'netlink/Makefile.am')
-rw-r--r--netlink/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/netlink/Makefile.am b/netlink/Makefile.am
new file mode 100644
index 0000000..f33d36d
--- /dev/null
+++ b/netlink/Makefile.am
@@ -0,0 +1,41 @@
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall -I@TOOLKIT_INCLUDE@
+
+lib_LTLIBRARIES = librtnl.la
+
+librtnl_la_SOURCES = \
+ librtnl/netns.c \
+ librtnl/rtnl.c \
+ librtnl/mapper.c
+
+nobase_include_HEADERS = \
+ librtnl/netns.h \
+ librtnl/rtnl.h \
+ librtnl/mapper.h
+
+
+lib_LTLIBRARIES += testrtnl_plugin.la
+
+testrtnl_plugin_la_SOURCES = test/test.c
+testrtnl_plugin_la_LDFLAGS = -module
+
+
+if WITH_PLUGIN_TOOLKIT
+install-data-hook:
+ mkdir /usr/lib/vpp_plugins || true
+ cp $(prefix)/lib/testnl_plugin.so.*.*.* /usr/lib/vpp_plugins
+endif