aboutsummaryrefslogtreecommitdiffstats
path: root/router/Makefile.am
diff options
context:
space:
mode:
authorJeff Shaw <jeffrey.b.shaw@intel.com>2016-06-17 12:02:48 -0700
committerJeff Shaw <jeffrey.b.shaw@intel.com>2016-06-17 13:40:29 -0700
commit061c542db7c6616d3698717d6b857914c3e2ca92 (patch)
tree872a914f8c44200efb7e6ec5d841b01962cd66aa /router/Makefile.am
parent9f07da4aea0683dec4fdcd270c80e68b4acd057a (diff)
router: initial commit
Change-Id: Ief5544e58f002e8d33b72dd87295c29f93345d37 Signed-off-by: Jeff Shaw <jeffrey.b.shaw@intel.com>
Diffstat (limited to 'router/Makefile.am')
-rw-r--r--router/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/router/Makefile.am b/router/Makefile.am
new file mode 100644
index 0000000..2e9b38f
--- /dev/null
+++ b/router/Makefile.am
@@ -0,0 +1,14 @@
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall -I@TOOLKIT_INCLUDE@
+
+lib_LTLIBRARIES = router.la
+router_la_SOURCES = router/router.c
+router_la_LDFLAGS = -module
+router_la_LIBADD = -lrtnl
+
+if WITH_PLUGIN_TOOLKIT
+install-data-hook:
+ mkdir /usr/lib/vpp_plugins || true
+ cp $(prefix)/lib/router.so.*.*.* /usr/lib/vpp_plugins
+endif