aboutsummaryrefslogtreecommitdiffstats
path: root/turbotap/configure.ac
diff options
context:
space:
mode:
authorMohsin KAZMI <sykazmi@cisco.com>2016-08-10 15:51:17 +0200
committerMohsin KAZMI <sykazmi@cisco.com>2016-08-10 17:33:56 +0200
commitadff8bfb431798fc1d4e4571d53074dc3438d14f (patch)
treeac73cd352be4eba5d1dac60596a39f4bc72b711d /turbotap/configure.ac
parent5d7ae6ad224dab352219e3a60d40f0ed5af2be22 (diff)
turbotap: A plugin for turbo tap interfaces
This patch implements a plugin for tap interfaces using socket API. It has advantage of reduced context switching over traditional tap interfaces using "sendmmsg" or "recvmmsg" system calls to send/receive multiple packets using single system call. Change-Id: I5b98e403692ac47d119c03174a21fbd9ff24de82 Signed-off-by: Mohsin KAZMI <sykazmi@cisco.com>
Diffstat (limited to 'turbotap/configure.ac')
-rw-r--r--turbotap/configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/turbotap/configure.ac b/turbotap/configure.ac
new file mode 100644
index 0000000..a1d4311
--- /dev/null
+++ b/turbotap/configure.ac
@@ -0,0 +1,26 @@
+AC_INIT(turbotap, 1.0)
+LT_INIT
+AM_INIT_AUTOMAKE
+
+AM_PROG_AS
+AC_PROG_CC
+AM_PROG_CC_C_O
+
+AC_ARG_WITH(dpdk,
+ AC_HELP_STRING([--with-dpdk],[Use the Intel dpdk]),
+ [with_dpdk=1],
+ [with_dpdk=0])
+
+AC_ARG_WITH(plugin-toolkit,
+ AC_HELP_STRING([--with-plugin-toolkit],
+ [build using the vpp toolkit]),
+ [with_plugin_toolkit=${prefix}/include],
+ [with_plugin_toolkit=.])
+
+AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
+AC_SUBST(DPDK,["-DDPDK=1"])
+
+AC_SUBST(TOOLKIT_INCLUDE,[${with_plugin_toolkit}])
+AM_CONDITIONAL(WITH_PLUGIN_TOOLKIT, test "$with_plugin_toolkit" != ".")
+
+AC_OUTPUT([Makefile])