aboutsummaryrefslogtreecommitdiffstats
path: root/vcl-ldpreload/src/Makefile.am
diff options
context:
space:
mode:
authorshrinivasan ganapathy <shrinivasanganapathy@gmail.com>2017-08-11 12:14:05 -0700
committershrinivasan ganapathy <shrinivasanganapathy@gmail.com>2017-08-17 10:36:00 -0700
commite1b749ab40f057bc5098a882b60e3a20da1cf1f9 (patch)
treeb8a9b4d7b435da05f28fb0f5198ad03403c49292 /vcl-ldpreload/src/Makefile.am
parente6f61ec6c384d68cc3623f6a1070d9234eeed610 (diff)
VCL-LDPRELOAD LIBRARY
A LD_PRELOAD library built on top of VCL library - initial creation. - User can LD_PRELOAD any application that uses POSIX socket API and yet reap the benifits of VPP transport. - addressed review comments - fix bug in vcom_select rv was always zero. - updated README.md with instructions to use socket_test.sh script Signed-off-by: shrinivasan ganapathy <shrinivasanganapathy@gmail.com> new file: vcl-ldpreload/LICENSE new file: vcl-ldpreload/MAINTAINERS new file: vcl-ldpreload/src/Makefile.am new file: vcl-ldpreload/src/configure.ac new file: vcl-ldpreload/src/libvcl-ldpreload.am new file: vcl-ldpreload/src/libvcl-ldpreload/TODO new file: vcl-ldpreload/src/libvcl-ldpreload/vcom.c new file: vcl-ldpreload/src/libvcl-ldpreload/vcom.h new file: vcl-ldpreload/src/libvcl-ldpreload/vcom_glibc_socket.h new file: vcl-ldpreload/src/libvcl-ldpreload/vcom_socket.c new file: vcl-ldpreload/src/libvcl-ldpreload/vcom_socket.h new file: vcl-ldpreload/src/libvcl-ldpreload/vcom_socket_wrapper.c new file: vcl-ldpreload/src/libvcl-ldpreload/vcom_socket_wrapper.h new file: vcl-ldpreload/src/vcl-ldpreload.mk new file: vcl-ldpreload/test/README.md Change-Id: I0db70bc4c3b3bac35451afa432c20dc04cb9699c Signed-off-by: shrinivasan ganapathy <shrinivasanganapathy@gmail.com>
Diffstat (limited to 'vcl-ldpreload/src/Makefile.am')
-rw-r--r--vcl-ldpreload/src/Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/vcl-ldpreload/src/Makefile.am b/vcl-ldpreload/src/Makefile.am
new file mode 100644
index 0000000..7f16e00
--- /dev/null
+++ b/vcl-ldpreload/src/Makefile.am
@@ -0,0 +1,62 @@
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+###############################################################################
+# Global Defines
+###############################################################################
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+ACLOCAL_AMFLAGS = -I m4
+AM_LIBTOOLFLAGS = --quiet
+
+AM_CFLAGS = -Wall -fstack-protector -fPIC -Werror -g -DFORTIFY_SOURCE=2
+AM_LDFLAGS = -shared
+
+if VPP_DEBUG
+AM_CFLAGS += -O0 -DCLIB_DEBUG
+vpp_build = vpp_debug-native
+else
+AM_CFLAGS += -O2
+vpp_build = vpp-native
+endif
+
+if VCL_LDPRELOAD_DEBUG
+AM_CFLAGS += -ggdb '-DVCOM_DEBUG=1'
+else
+AM_CFLAGS += -Wall '-DVCOM_DEBUG=0'
+endif
+
+if VPP_DIR_SET
+vpp_install = @VPP_DIR@/build-root/install-$(vpp_build)
+AM_CFLAGS += -I$(vpp_install)/vpp/include/
+AM_LDFLAGS += -L$(vpp_install)/vpp/lib64/
+endif
+
+
+AM_LDFLAGS += -lvppcom -lvppinfra
+
+SUBDIRS = .
+noinst_HEADERS =
+dist_bin_SCRIPTS =
+lib_LTLIBRARIES =
+BUILT_SOURCES =
+CLEANFILES =
+
+
+###############################################################################
+# Components
+###############################################################################
+
+include libvcl-ldpreload.am
+
+