aboutsummaryrefslogtreecommitdiffstats
path: root/turbotap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'turbotap/Makefile.am')
-rw-r--r--turbotap/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/turbotap/Makefile.am b/turbotap/Makefile.am
new file mode 100644
index 0000000..8ea9c3f
--- /dev/null
+++ b/turbotap/Makefile.am
@@ -0,0 +1,18 @@
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall -I@TOOLKIT_INCLUDE@ @DPDK@
+AM_LDFLAGS = -module -shared -avoid-version
+
+lib_LTLIBRARIES = libturbotap.la
+libturbotap_la_SOURCES = turbotap/turbotap.c\
+ turbotap/device.c \
+ turbotap/node.c \
+ turbotap/cli.c
+
+nobase_include_HEADERS = turbotap/turbotap.h
+
+if WITH_PLUGIN_TOOLKIT
+install-data-hook:
+ mkdir /usr/lib/vpp_plugins || true
+ cp $(prefix)/lib/turbotap.so.*.*.* /usr/lib/vpp_plugins
+endif