aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nginx-dl.mk
diff options
context:
space:
mode:
authorxiaolongx.jiang <xiaolongx.jiang@intel.com>2020-05-12 05:07:26 +0000
committerxiaolongx.jiang <xiaolongx.jiang@intel.com>2020-05-15 16:42:40 +0000
commit5fad054675b47633f5ba1e33f775e34be4917c06 (patch)
tree49a3eafb868726c4478c18f7dc732799228c3c4b /packages/nginx-dl.mk
parent1e75471aed27194fb8ee0b2c07c64fb8a8f55279 (diff)
add makefile
Signed-off-by: xiaolongx.jiang <xiaolongx.jiang@intel.com> Change-Id: Iaf6ec4d79538f8810d0c0ebc69b458d40ffb9c53
Diffstat (limited to 'packages/nginx-dl.mk')
-rw-r--r--packages/nginx-dl.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/nginx-dl.mk b/packages/nginx-dl.mk
new file mode 100644
index 0000000..7fc7bd3
--- /dev/null
+++ b/packages/nginx-dl.mk
@@ -0,0 +1,20 @@
+# Copyright (c) 2020 Intel and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+nginx_version := 1.14.2
+nginx_tarball := nginx-$(nginx_version).tar.gz
+nginx_tarball_md5sum := 239b829a13cea1d244c1044e830bd9c2
+nginx_url := http://nginx.org/download/$(nginx_tarball)
+
+
+$(eval $(call download,nginx))