aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-11-22 11:55:46 +0000
committerGerrit Code Review <gerrit@fd.io>2019-11-22 11:55:46 +0000
commit4d593c09d9cc1496788f7953de25832193064103 (patch)
treef066cb1cc2d5910ed1f84613f652e27bf6fc7a6c /CMakeLists.txt
parent7efe8c9372615d0333d1aa045de5d0c4a171a978 (diff)
parent4eb89ea4dcad4c01664b5331745f4e9a38facbd2 (diff)
Merge "[HICN-394] Add route commands add, list, del for the hicn-plugin"
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5977b7955..9bff3d35e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,15 +29,16 @@ option(BUILD_CTRL "Build the hicn control tools" ON)
option(BUILD_HICNPLUGIN "Build the hicn vpp plugin" OFF)
option(BUILD_HICNEXTRAPLUGIN "Build the hicn extra plugin" OFF)
option(BUILD_SYSREPOPLUGIN "Build the sysrepo plugin" OFF)
+option(BUILD_CTRL_HICNPLUGIN "Build the hicn control tools for hicn plugin" OFF)
list(APPEND dir_options
BUILD_LIBHICN
BUILD_HICNLIGHT
+ BUILD_HICNPLUGIN
BUILD_LIBTRANSPORT
BUILD_UTILS
BUILD_APPS
BUILD_CTRL
- BUILD_HICNPLUGIN
BUILD_HICNEXTRAPLUGIN
BUILD_SYSREPOPLUGIN
BUILD_LIBMEMIF
@@ -92,11 +93,6 @@ if (BUILD_HICNPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
unset(LIBMEMIF_LIBRARIES)
endif()
- list(APPEND HICN_BINARY_API_INCLUDE_DIRS
- ${PROJECT_BINARY_DIR}/hicn-plugin
- ${PROJECT_BINARY_DIR}/hicn-plugin/vpp_plugins
- )
-
set(LIBTRANSPORT ${LIBTRANSPORT}-memif)
endif()