aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Muscariello <muscariello@ieee.org>2022-08-11 18:30:53 +0200
committerLuca Muscariello <muscariello@ieee.org>2022-08-11 18:30:53 +0200
commit55343701359194493fbd9ff4950ac4f941bbdae3 (patch)
tree4583baaebd2a715d225054c845a36dc9f63c86ba /CMakeLists.txt
parentb9ed4b7dd6c2342bc87209d415b840d65ea5ccf0 (diff)
feat: drop sysrepo and netconf/yang support
Signed-off-by: Luca Muscariello <muscariello@ieee.org> Change-Id: I215af1b77a3f9da878f3894708f687a7e7ea03a2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41ecda018..26783d544 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -102,7 +102,6 @@ else ()
option(DISABLE_SHARED_LIBRARIES "Disable shared libraries" ON)
endif ()
option(BUILD_HICNPLUGIN "Build the hicn vpp plugin" OFF)
-option(BUILD_SYSREPOPLUGIN "Build the sysrepo plugin" OFF)
option(BUILD_EXTRAS "Build external projects" OFF)
option(BUILD_TELEMETRY "Build telemetry projects" OFF)
option(BUILD_TESTS "Build unit tests" OFF)
@@ -117,11 +116,6 @@ if (BUILD_APPS AND NOT BUILD_LIBTRANSPORT)
set (BUILD_LIBTRANSPORT ON)
endif()
-if (BUILD_SYSREPOPLUGIN AND NOT BUILD_HICNPLUGIN)
- message(STATUS "Hicn-plugin required. Enabled by default.")
- set (BUILD_HICNPLUGIN ON)
-endif()
-
if ((BUILD_HICNLIGHT OR
BUILD_LIBTRANSPORT OR
BUILD_APPS OR
@@ -151,7 +145,6 @@ set(BUILD_LIBTRANSPORT_DIR libtransport)
set(BUILD_APPS_DIR apps)
set(BUILD_CTRL_DIR ctrl)
set(BUILD_HICNPLUGIN_DIR hicn-plugin)
-set(BUILD_SYSREPOPLUGIN_DIR ctrl/sysrepo-plugins)
set(BUILD_EXTRAS_DIR extras/)
set(BUILD_TELEMETRY_DIR telemetry)