aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormasoud hemmatpour <mhemmatp@cisco.com>2019-07-08 04:41:52 -0700
committermhemmatp <mhemmatp@cisco.com>2019-07-24 01:35:40 -0700
commit7fa802ce1b196b9cac723852092d8df1e7783267 (patch)
tree9826678b75bd848798fe1370c3d90d3d5147074b /CMakeLists.txt
parent4d86f3ed3c000a5cfa96ad24cf77d57bc1a811e8 (diff)
[HICN-243] Adding router plugin
The original package is https://gerrit.fd.io/r/#/c/15062/ which was compatible with VPP 18.10. This patch is the modification of the original to be compatible with VPP 19.04. It was tested with FRR (i.e., OSPF). Change-Id: I85d579b26be2ef68f1b4a1d54e5c599b3665574b Signed-off-by: masoud hemmatpour <mhemmatp@cisco.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 63c438fd8..34105c7f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ option(BUILD_LIBTRANSPORT "Build the hicn transport library" ON)
option(BUILD_UTILS "Build the hicn utils" ON)
option(BUILD_APPS "Build the hicn apps" OFF)
option(BUILD_HICNPLUGIN "Build the hicn vpp plugin" OFF)
+option(BUILD_HICNEXTRAPLUGIN "Build the hicn extra plugin" OFF)
list(APPEND dir_options
BUILD_LIBHICN
@@ -43,6 +44,8 @@ set(BUILD_LIBTRANSPORT_DIR libtransport)
set(BUILD_UTILS_DIR utils)
set(BUILD_APPS_DIR apps)
set(BUILD_HICNPLUGIN_DIR hicn-plugin)
+set(BUILD_HICNEXTRAPLUGIN_DIR utils/extras/)
+
## HEADER FILES
set(LIBHICN_HEADER_FILES)
@@ -64,6 +67,7 @@ set(LIBHICN_LIGHT hicn-light)
set(HICN_LIGHT_CONTROL hicn-light-control)
set(HICN_LIGHT_DAEMON hicn-light-daemon)
set(HICN_PLUGIN hicn-plugin)
+set(HICN_EXTRA_PLUGIN hicn-extra-plugin)
set(LIBTRANSPORT hicntransport)
set(HICN_UTILS hicn-utils)
set(HICN_APPS hicn-apps)
@@ -81,6 +85,12 @@ if (BUILD_HICNPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
set(LIBTRANSPORT ${LIBTRANSPORT}-memif)
endif()
+if (BUILD_HICNEXTRAPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+ list(APPEND subdirs
+ ${BUILD_HICNEXTRAPLUGIN_DIR}
+ )
+endif()
+
## Shared targets
set(LIBHICN_SHARED ${LIBHICN}.shared)
set(LIBTRANSPORT_SHARED ${LIBTRANSPORT}.shared)
@@ -96,4 +106,4 @@ foreach(dir ${subdirs})
endforeach()
include(Packager)
-make_packages() \ No newline at end of file
+make_packages()