aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Muscariello <muscariello@ieee.org>2021-03-25 21:28:23 +0000
committerGerrit Code Review <gerrit@fd.io>2021-03-25 21:28:23 +0000
commitb8e7a5c2deed533eea900b7f76389bd52935f5fd (patch)
tree4af8baeeb38e7f5f2d4cff0086e51782d8912793 /CMakeLists.txt
parent89f4349506024b9d4c35c018f471087a0f562c52 (diff)
parent9f30bf6e794a7b431217ce91038a4ec0f917dc08 (diff)
Merge "[HICN-688] Include packethicn in hicn build"
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31f40aaa6..d6d67ec9f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,7 @@ endif ()
option(BUILD_HICNPLUGIN "Build the hicn vpp plugin" OFF)
option(BUILD_SYSREPOPLUGIN "Build the sysrepo plugin" OFF)
option(BUILD_EXTRAS "Build external projects" OFF)
+option(BUILD_WSPLUGIN "Build the hicn plugin for wireshark" OFF)
option(BUILD_TELEMETRY "Build telemetry projects" OFF)
option(BUILD_TESTS "Build unit tests" OFF)
option(DISABLE_EXECUTABLES "Disable executables" OFF)
@@ -71,6 +72,7 @@ list(APPEND dir_options
BUILD_APPS
BUILD_SYSREPOPLUGIN
BUILD_EXTRAS
+ BUILD_WSPLUGIN
BUILD_TELEMETRY
)
@@ -83,6 +85,7 @@ set(BUILD_CTRL_DIR ctrl)
set(BUILD_HICNPLUGIN_DIR hicn-plugin)
set(BUILD_SYSREPOPLUGIN_DIR ctrl/sysrepo-plugins)
set(BUILD_EXTRAS_DIR extras/)
+set(BUILD_WSPLUGIN_DIR extras/packethicn)
set(BUILD_TELEMETRY_DIR telemetry)
## Add enabled components