aboutsummaryrefslogtreecommitdiffstats
path: root/apps/higet/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-05-19 15:23:13 +0000
committerGerrit Code Review <gerrit@fd.io>2019-05-19 15:23:13 +0000
commit250e5f768a75a62b001c16932e06055fa64a1a27 (patch)
tree9ac0ac8d50b49faf9d556e914f6d573372eaca70 /apps/higet/CMakeLists.txt
parent0d967df60ea818382dca57316a022b6b967c9254 (diff)
parent7c0e5b9cd797e9bed98fc8d1df411894a4174d87 (diff)
Merge "[HICN-202] Compile apps in release mode if no build mode is specified"
Diffstat (limited to 'apps/higet/CMakeLists.txt')
-rw-r--r--apps/higet/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/apps/higet/CMakeLists.txt b/apps/higet/CMakeLists.txt
index 8c7188c49..747760f00 100644
--- a/apps/higet/CMakeLists.txt
+++ b/apps/higet/CMakeLists.txt
@@ -22,6 +22,11 @@ set(CMAKE_MODULE_PATH
"${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules"
)
+if (NOT CMAKE_BUILD_TYPE)
+ message(STATUS "No build type selected, default to Release")
+ set(CMAKE_BUILD_TYPE "Release")
+endif ()
+
list(APPEND APPS_SRC
higet.cc
)