aboutsummaryrefslogtreecommitdiffstats
path: root/apps/http-proxy/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-11-22 15:22:41 +0100
committerAlberto Compagno <acompagn+fdio@cisco.com>2019-11-22 15:22:41 +0100
commitaa85de386a9de70fb7721ccecb5d1b9c97035c6a (patch)
tree3ad23177443a881048c6b33f3dfea4f39f7dedc3 /apps/http-proxy/CMakeLists.txt
parentfc47fb553d3ab61079bb288942b0328e4b3392fb (diff)
[HICN-412] Added option LINK_FLAGSgto build_executable to specify link flags
Change-Id: I6b382abe374d896c9ea1e0ef5573ba166fafec94 Signed-off-by: Alberto Compagno <acompagn+fdio@cisco.com>
Diffstat (limited to 'apps/http-proxy/CMakeLists.txt')
-rw-r--r--apps/http-proxy/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/apps/http-proxy/CMakeLists.txt b/apps/http-proxy/CMakeLists.txt
index 7e29edcf8..cc47e4b6f 100644
--- a/apps/http-proxy/CMakeLists.txt
+++ b/apps/http-proxy/CMakeLists.txt
@@ -55,6 +55,7 @@ build_library(${LIBHTTP_PROXY}
LINK_LIBRARIES ${LIBRARIES}
DEPENDS ${DEPENDENCIES}
INCLUDE_DIRS ${LIBTRANSPORT_INCLUDE_DIRS}
+ LINK_FLAGS ${LINK_FLAGS}
)
build_executable(${HTTP_PROXY}
@@ -63,4 +64,5 @@ build_executable(${HTTP_PROXY}
DEPENDS ${LIBHTTP_PROXY_STATIC}
COMPONENT ${HICN_APPS}
DEFINITIONS ${COMPILER_DEFINITIONS}
+ LINK_FLAGS ${LINK_FLAGS}
)