aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/libhicnctrl/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Augé <jordan.auge+fdio@cisco.com>2019-07-26 23:20:30 +0200
committerMauro Sardara <msardara@cisco.com>2019-07-29 17:13:35 +0200
commit0a1c6b5565e20167d1f1f33a5a8b597f420b18b0 (patch)
tree98c5da8f231fbd3dc2ce6502040e29c8333d9ffc /ctrl/libhicnctrl/src/CMakeLists.txt
parent05ca0aa8f612ee48fb66d4dbebe596b7f1e03181 (diff)
[HICN-252] Add per-application policy framework to hicn-light forwarder
Change-Id: I0531cd7a7de179581295ae34766c81cd9cf3e172 Signed-off-by: Jordan Augé <jordan.auge+fdio@cisco.com> Signed-off-by: Mauro Sardara <msardara@cisco.com> Co-authored-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'ctrl/libhicnctrl/src/CMakeLists.txt')
-rw-r--r--ctrl/libhicnctrl/src/CMakeLists.txt87
1 files changed, 87 insertions, 0 deletions
diff --git a/ctrl/libhicnctrl/src/CMakeLists.txt b/ctrl/libhicnctrl/src/CMakeLists.txt
new file mode 100644
index 000000000..ebccb7ddd
--- /dev/null
+++ b/ctrl/libhicnctrl/src/CMakeLists.txt
@@ -0,0 +1,87 @@
+# Copyright (c) 2017-2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+include(BuildMacros)
+
+list(APPEND COMPILER_DEFINITIONS
+ "-DWITH_POLICY"
+# "-DWITH_UPDATE"
+)
+
+set(HEADER_FILES
+ api.h
+ commands.h
+ face.h
+)
+
+set(UTIL_HEADER_FILES
+ face.h
+ util/ip_address.h
+ util/log.h
+ util/policy.h
+ util/token.h
+ util/types.h
+)
+
+set(SOURCE_FILES
+ api.c
+ util/policy.c
+ util/log.c
+)
+
+set(LIBRARIES
+ m
+)
+
+set(INCLUDE_DIRS
+ ./
+ ../includes/
+)
+
+if (ANDROID_API)
+ build_library(${LIBHICN_CTRL}
+ STATIC
+ SOURCES ${SOURCE_FILES}
+ INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
+ LINK_LIBRARIES ${LIBRARIES}
+ COMPONENT ${LIBHICNCTRL_COMPONENT}
+ INCLUDE_DIRS ${INCLUDE_DIRS}
+ INSTALL_ROOT_DIR hicn
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ )
+else ()
+ build_library(${LIBHICN_CTRL}
+ SHARED STATIC
+ SOURCES ${SOURCE_FILES}
+ INSTALL_HEADERS ${TO_INSTALL_HEADER_FILES}
+ LINK_LIBRARIES ${LIBRARIES}
+ COMPONENT ${LIBHICNCTRL_COMPONENT}
+ INCLUDE_DIRS ${INCLUDE_DIRS}
+ INSTALL_ROOT_DIR hicn
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ )
+endif ()
+
+if(NOT ANDROID_API AND NOT COMPILE_FOR_IOS)
+ list(APPEND DAEMON_SRC
+ cli.c
+ )
+ build_executable(${HICN_CTRL}
+ SOURCES ${DAEMON_SRC}
+ LINK_LIBRARIES ${LIBHICN_CTRL_SHARED}
+ DEPENDS ${LIBHICN_CTRL_SHARED}
+ COMPONENT ${LIBHICNCTRL_COMPONENT}
+ INCLUDE_DIRS ${INCLUDE_DIRS}
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ )
+endif ()