aboutsummaryrefslogtreecommitdiffstats
path: root/extras/libyang/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-12-04 09:56:31 +0000
committerGerrit Code Review <gerrit@fd.io>2019-12-04 09:56:31 +0000
commita90afcecc8029648c0e4ef2b79234eca8c31eac9 (patch)
treee50d15b2457b508ede84a7639282db239353325d /extras/libyang/CMakeLists.txt
parent0a60657a56073c1c1d043a63b93cffd764ca40d3 (diff)
parent2bfd3335ff11281d703cb7f422bb17da2d3a6bcd (diff)
Merge "to fix HICN-421 by adding cpack to libyang and sysrepo"
Diffstat (limited to 'extras/libyang/CMakeLists.txt')
-rw-r--r--extras/libyang/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/extras/libyang/CMakeLists.txt b/extras/libyang/CMakeLists.txt
new file mode 100644
index 000000000..734e14641
--- /dev/null
+++ b/extras/libyang/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Copyright (c) 2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+cmake_minimum_required(VERSION 2.8)
+project(libyang)
+
+set(CMAKE_MODULE_PATH
+ ${CMAKE_MODULE_PATH}
+ "${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/Modules"
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules"
+)
+
+include(ExternalProject)
+include(Packaging)
+
+if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
+ set(LIBYANG libyang)
+endif()
+
+execute_process(
+ COMMAND bash -c "if [ ! -d libyang ]; then
+ git clone https://github.com/CESNET/libyang.git -b devel --depth 1 libyang;
+ cd libyang; git apply ${CMAKE_CURRENT_SOURCE_DIR}/libyang.patch;
+ else
+ pushd libyang && git pull && popd;
+ fi"
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+add_subdirectory(${CMAKE_CURRENT_BINARY_DIR}/libyang ${CMAKE_CURRENT_BINARY_DIR}/libyang)
+
+include(Packaging)
+if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
+ include(Packager)
+ make_packages()
+endif() \ No newline at end of file