aboutsummaryrefslogtreecommitdiffstats
path: root/extras/packethicn/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Trinelli <marcotrinelli@gmail.com>2021-04-08 11:33:02 +0200
committerMarco Trinelli <marcotrinelli@gmail.com>2021-04-09 13:15:31 +0200
commitcd0aa7de71b4f514879b8fc40c57665bbf93c0cd (patch)
tree609153e6416a7832c4de705cd05150439eb5d35c /extras/packethicn/CMakeLists.txt
parentf72849911653de9239f3b32359f38b0c5ed90ac6 (diff)
[HICN-696] packethicn: add support for native hicn and fix find wireshark for macOS
Allow wireshark to parse native hicn traffic (decode IPv6 traffic as HICN, by default) Fix find_package(wireshark) for macOS, to automatically find wireshark sources in macOS Signed-off-by: Marco Trinelli <marcotrinelli@gmail.com> Change-Id: I95599a894b91685ab1f274b1fa8d75efe6b96178 Signed-off-by: Marco Trinelli <marcotrinelli@gmail.com>
Diffstat (limited to 'extras/packethicn/CMakeLists.txt')
-rw-r--r--extras/packethicn/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/extras/packethicn/CMakeLists.txt b/extras/packethicn/CMakeLists.txt
index f8be36eff..cb168ae1f 100644
--- a/extras/packethicn/CMakeLists.txt
+++ b/extras/packethicn/CMakeLists.txt
@@ -24,7 +24,13 @@ set(CMAKE_MODULE_PATH
set(PACKETHICN packethicn)
-find_package(Wireshark CONFIG REQUIRED)
+if(APPLE)
+ find_package(Wireshark CONFIG REQUIRED
+ PATHS /usr/local/opt/wireshark/lib/wireshark/cmake/ /usr/local/Cellar/wireshark/*/lib/wireshark/cmake
+ )
+else()
+ find_package(Wireshark CONFIG REQUIRED)
+endif()
MATH(EXPR Wireshark_PATCH_NEXT_VERSION "${Wireshark_PATCH_VERSION}+1")
set(Wireshark_NEXT_VERSION ${Wireshark_MAJOR_VERSION}.${Wireshark_MINOR_VERSION}.${Wireshark_PATCH_NEXT_VERSION})
@@ -32,8 +38,8 @@ set(Wireshark_NEXT_VERSION ${Wireshark_MAJOR_VERSION}.${Wireshark_MINOR_VERSION}
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package(Libhicn REQUIRED)
else()
- if (DISABLE_SHARED_LIBRARIES)
- if (WIN32)
+ if(DISABLE_SHARED_LIBRARIES)
+ if(WIN32)
set(HICN_LIBRARIES ${LIBHICN_STATIC})
else()
set(HICN_LIBRARIES ${LIBHICN_STATIC} log)