aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-02-22 18:09:48 +0100
committerMauro Sardara <msardara@cisco.com>2019-02-22 17:32:52 +0000
commitbb428fc90f2623bdf35c53e62bf2aaeba2d1e0b7 (patch)
tree2994228aff181f0e8adde36a77f0b2287d13cbc2 /hicn-light/CMakeLists.txt
parentfccece7f012c209f04d9f9be4a10073536091914 (diff)
[HICN-83] Added cmake flag "-DENABLE_PUNTING=[ON|OFF]" for enabling/disabling punting in hicnLightDaemon.
Change-Id: I14f5e1ce21f2c2381359fa6184671d3cbe43b808 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'hicn-light/CMakeLists.txt')
-rw-r--r--hicn-light/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/hicn-light/CMakeLists.txt b/hicn-light/CMakeLists.txt
index 7df740b4c..0d9e4d261 100644
--- a/hicn-light/CMakeLists.txt
+++ b/hicn-light/CMakeLists.txt
@@ -16,6 +16,8 @@ set(CMAKE_MODULE_PATH
set(CMAKE_C_STANDARD 11)
set(CMAKE_C_STANDARD_REQUIRED ON)
+option(ENABLE_PUNTING "Enable punting on linux systems" ON)
+
include( CTest )
include( detectCacheSize )
@@ -24,10 +26,11 @@ if(NOT WIN32)
else ()
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /wd4996")
endif ()
+
if(ANDROID_API)
message("############ Detected cross compile for $ENV{CMAKE_SYSTEM_NAME}")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${ANDROID_C_FLAGS}")
- endif()
+endif()
set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -DLIBRTA_DISABLE_VALIDATION -DPARCLibrary_DISABLE_VALIDATION")