aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-05-03 15:11:28 +0200
committerAlberto Compagno <acompagn+fdio@cisco.com>2019-05-07 14:35:59 +0200
commit3ba9071c6899d64b36e910943f109ddc7c7e0809 (patch)
treedbfe4c6f2b10c4b7c824cc8b4c6d4003ba5422b3 /hicn-plugin/CMakeLists.txt
parentcd48bbd9685f042a2f1f90678f8fa98a5175ea4d (diff)
[HICN-181] Added round robin strategy
Change-Id: I301ffaeed6f43b7db6701810167f02947439d20c Signed-off-by: Alberto Compagno <acompagn+fdio@cisco.com>
Diffstat (limited to 'hicn-plugin/CMakeLists.txt')
-rw-r--r--hicn-plugin/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/hicn-plugin/CMakeLists.txt b/hicn-plugin/CMakeLists.txt
index 1cd6f0411..be71b36a3 100644
--- a/hicn-plugin/CMakeLists.txt
+++ b/hicn-plugin/CMakeLists.txt
@@ -113,6 +113,8 @@ set(HICN_PLUGIN_SOURCE_FILES
src/strategies/dpo_mw.c
src/strategies/strategy_mw.c
src/strategies/strategy_mw_cli.c
+ src/strategies/dpo_rr.c
+ src/strategies/strategy_rr.c
src/cache_policies/cs_lru.c
src/mapme_ack_node.c
src/mapme_ctrl_node.c
@@ -158,6 +160,8 @@ set(HICN_PLUGIN_HEADER_FILES
src/pg.h
src/strategies/dpo_mw.h
src/strategies/strategy_mw.h
+ src/strategies/dpo_rr.h
+ src/strategies/strategy_rr.h
src/cache_policies/cs_policy.h
src/cache_policies/cs_lru.h
src/mapme.h
@@ -275,4 +279,4 @@ install(FILES ${HICN_API_TEST_HEADER_FILES} ${HICN_API_GENERATED_FILES}
install(FILES ${HICN_VAPI_GENERATED_FILES}
DESTINATION ${CMAKE_INSTALL_PREFIX}/include/vapi
- COMPONENT ${HICN_PLUGIN}) \ No newline at end of file
+ COMPONENT ${HICN_PLUGIN})