aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-10-01 18:09:01 +0200
committerAlberto Compagno <acompagn+fdio@cisco.com>2019-10-06 23:27:05 +0200
commitdf63161bafa18c05318e7a87fd6422b1095e1a5a (patch)
tree4175ab5b02251741bb63ff9e157c53a509700d44 /hicn-plugin/CMakeLists.txt
parent85a791ac2cdd35d79c00141e748b4c68fbdafb0d (diff)
[HICN-287] Adding hicn section to the startup.conf
Checking if the size of the CS is greater than the number of vlib buffers available and size it accordingly. Removed unused parameters to set PIT lifetime Change-Id: I47679466542d4338e447d9e0b956038143164020 Signed-off-by: Alberto Compagno <acompagn+fdio@cisco.com>
Diffstat (limited to 'hicn-plugin/CMakeLists.txt')
-rw-r--r--hicn-plugin/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/hicn-plugin/CMakeLists.txt b/hicn-plugin/CMakeLists.txt
index 4a6d5e47d..0da096e22 100644
--- a/hicn-plugin/CMakeLists.txt
+++ b/hicn-plugin/CMakeLists.txt
@@ -189,6 +189,9 @@ set(HICN_VAPI_GENERATED_FILES
${CMAKE_CURRENT_BINARY_DIR}/vpp_plugins/hicn/hicn.api.vapi.h
${CMAKE_CURRENT_BINARY_DIR}/vpp_plugins/hicn/hicn.api.vapi.hpp)
+set(HICN_VPP_STARTUP_CONF_FILE
+ ${CMAKE_BINARY_DIR}/startup.conf)
+
if (NOT VPP_HOME)
set(VPP_HOME /usr)
endif()
@@ -266,6 +269,7 @@ add_library(hicn_api_test_plugin SHARED
set(VPP_INSTALL_PLUGIN ${HICN_INSTALL_PREFIX}/vpp_plugins)
set(VPP_INSTALL_API_TEST_PLUGIN ${HICN_INSTALL_PREFIX}/vpp_api_test_plugins CACHE STRING "vpp_install_api_test_plugin")
+set(VPP_STARTUP_CONF /etc/vpp/)
set_target_properties(hicn_plugin
PROPERTIES