aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2023-01-30 21:14:39 +0000
committerMauro Sardara <msardara@cisco.com>2023-02-13 09:26:06 +0000
commitc46b82460987912eb465187892286922aeaedab4 (patch)
tree340369094db2fcc8023668f924d8e561547714bb /hicn-plugin/src/CMakeLists.txt
parentdf902fa5ea07a0de312b1b6dd138e360611e5769 (diff)
feat(hicn-plugin): handle case of no exact match for mapme IU
Ticket: HICN-844 Change-Id: I1f046e6327e4cf507b7fa7a5adae53e63ab491bf Signed-off-by: Mauro Sardara <msardara@cisco.com> (cherry picked from commit 7cfd91a6c6316fe15186c8cd3acc1c4526db7e25)
Diffstat (limited to 'hicn-plugin/src/CMakeLists.txt')
-rw-r--r--hicn-plugin/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/hicn-plugin/src/CMakeLists.txt b/hicn-plugin/src/CMakeLists.txt
index 9524b011a..b7fa828f3 100644
--- a/hicn-plugin/src/CMakeLists.txt
+++ b/hicn-plugin/src/CMakeLists.txt
@@ -179,6 +179,7 @@ set(COMPILER_OPTIONS
##############################################################
set(COMPILE_DEFINITIONS
"-DHICN_VPP_PLUGIN=1"
+ "-DHICN_MAPME_ALLOW_NONEXISTING_FIB_ENTRY"
)
if (${CMAKE_BUILD_TYPE} MATCHES "Debug")