aboutsummaryrefslogtreecommitdiffstats
path: root/lib/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Muscariello <lumuscar@cisco.com>2022-06-09 21:34:09 +0200
committerLuca Muscariello <muscariello@ieee.org>2022-06-30 10:47:50 +0200
commit6b94663b2455e212009a544ae23bb6a8c55407f8 (patch)
tree0af780ce5eeb1009fd24b8af8af08e8368eda3bd /lib/src/CMakeLists.txt
parenta1ac96f497719b897793ac14b287cb8d840651c1 (diff)
refactor(lib, hicn-light, vpp, hiperf): HICN-723
- move infra data structure into the shared lib - new packet cache using double hashing and lookup on prefix suffix - testing updates - authenticated requests using interest manifests Co-authored-by: Mauro Sardara <msardara@cisco.com> Co-authored-by: Jordan Augé <jordan.auge+fdio@cisco.com> Co-authored-by: Michele Papalini <micpapal@cisco.com> Co-authored-by: Olivier Roques <oroques+fdio@cisco.com> Co-authored-by: Enrico Loparco <eloparco@cisco.com> Change-Id: Iaddebfe6aa5279ea8553433b0f519578f6b9ccd9 Signed-off-by: Luca Muscariello <muscariello@ieee.org>
Diffstat (limited to 'lib/src/CMakeLists.txt')
-rw-r--r--lib/src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/src/CMakeLists.txt b/lib/src/CMakeLists.txt
index ef74127cc..8e81aa442 100644
--- a/lib/src/CMakeLists.txt
+++ b/lib/src/CMakeLists.txt
@@ -33,6 +33,9 @@ list(APPEND LIBHICN_SOURCE_FILES
protocol/new.c
util/ip_address.c
util/log.c
+ util/pool.c
+ util/ring.c
+ util/vector.c
)
if (WIN32)