aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-02-01 10:16:50 +0000
committerGerrit Code Review <gerrit@fd.io>2019-02-01 10:16:50 +0000
commitc00bc6fc2af9a54fe339f8d6a3ec1ab889c2931e (patch)
tree310460a90bcee82b05590849f2a213a0cca8b59a /libtransport/CMakeLists.txt
parent107e05eab1d032b9ac741f88a3bec8e60b22efc9 (diff)
parent1dea17fe921e1f94db63e4c563fe08dd25734900 (diff)
Merge "[HICN-10] Add support for building hicn-plugin packages. Do not build packages for components without name."
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--libtransport/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index c5cb95260..4df87b056 100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -44,7 +44,7 @@ set(raaqm_config_path ${CMAKE_INSTALL_PREFIX}/etc/hicn-consumer.conf)
# Install includes
set(INSTALL_INCLUDE_DIR include/hicn/transport)
-if ((BUILD_MEMIF_CONNECTOR OR BUILD_VPP_PLUGIN) AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+if (BUILD_VPP_PLUGIN AND BUILD_MEMIF_CONNECTOR AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
set(__vpp__ 1)
find_package(Vpp REQUIRED)
find_package(Libmemif REQUIRED)
@@ -116,4 +116,4 @@ list(APPEND LIBTRANSPORT_INCLUDE_DIRS
${WINDOWS_INCLUDE_DIRS}
)
-add_subdirectory(${TRANSPORT_ROOT_PATH}) \ No newline at end of file
+add_subdirectory(${TRANSPORT_ROOT_PATH})