aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2020-02-21 17:30:49 +0000
committerGerrit Code Review <gerrit@fd.io>2020-02-21 17:30:49 +0000
commite1135db42f05a94c6790c8650a3ac20396e0d78c (patch)
tree65b48490ced07f11597aedc2b752381b0d9e4b30 /libtransport/CMakeLists.txt
parent1b9512282a5324b2bd2b28b8e5555e15676cb54c (diff)
parent35058cdfe0134c88f1aa8d23342d1d7b9d39e296 (diff)
Merge "[HICN-2] Added P2P confidential communication on hICN"
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--libtransport/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index 8f70208ab..881e9810a 100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -75,6 +75,11 @@ include(WindowsMacros)
include(IosMacros)
find_package_wrapper(Libparc REQUIRED)
find_package_wrapper(Asio REQUIRED)
+find_package(OpenSSL REQUIRED)
+
+if (${OPENSSL_VERSION} VERSION_EQUAL "1.1.1a" OR ${OPENSSL_VERSION} VERSION_GREATER "1.1.1a")
+ set(SECURE_HICNTRANSPORT 1)
+endif()
if (__vpp__)
find_package(Libmemif REQUIRED)
@@ -139,6 +144,8 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Android")
find_package(OpenSSL REQUIRED)
endif ()
+message ("---------------------------> ${OPENSSL_LIBRARIES}")
+
list(APPEND LIBRARIES
${LIBPARC_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}
@@ -158,6 +165,7 @@ list(APPEND LIBTRANSPORT_INTERNAL_INCLUDE_DIRS
${CMAKE_THREADS_INCLUDE_DIRS}
${ASIO_INCLUDE_DIRS}
${WINDOWS_INCLUDE_DIRS}
+ ${OPENSSL_INCLUDE_DIR}
)
add_subdirectory(${TRANSPORT_ROOT_PATH})