aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-01-30 12:11:34 +0100
committerAngelo Mantellini <manangel@cisco.com>2019-01-30 15:23:44 +0100
commite5145b878f9de35676085409878a66899d2ee4f2 (patch)
tree177f77810901921ee03d1d3b850600c5f2cd1ef9 /libtransport/CMakeLists.txt
parent30061551cd39c9f30280bfa0cf3cc909f4fac015 (diff)
[HICN-18] first commit of libtransport for windows
Change-Id: I3a43b22194aa13ae5de1746e3d4bd9a275070261 Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--[-rwxr-xr-x]libtransport/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index 097ab03ab..c5cb95260 100755..100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -59,6 +59,7 @@ if ((BUILD_MEMIF_CONNECTOR OR BUILD_VPP_PLUGIN) AND "${CMAKE_SYSTEM_NAME}" STREQ
)
endif ()
+include(WindowsMacros)
include(IosMacros)
find_package_wrapper(Libparc REQUIRED)
find_package_wrapper(Asio REQUIRED)
@@ -102,6 +103,7 @@ list(APPEND LIBRARIES
${VPP_LIBRARIES}
${ANDROID_LIBRARIES}
${OPENSSL_LIBRARIES}
+ ${WINDOWS_LIBRARIES}
)
# Include dirs -- Order does matter!
@@ -111,6 +113,7 @@ list(APPEND LIBTRANSPORT_INCLUDE_DIRS
${LIBPARC_INCLUDE_DIRS}
${CMAKE_THREADS_INCLUDE_DIRS}
${ASIO_INCLUDE_DIRS}
+ ${WINDOWS_INCLUDE_DIRS}
)
add_subdirectory(${TRANSPORT_ROOT_PATH}) \ No newline at end of file